Ayuda a Firefox Multiproceso con Add-on Compatibility Reporter

Firefox está actualmente en transición a una arquitectura multiproceso (e10s), la cual dará a los usuarios una mayor estabilidad y una mejor respuesta del navegador. Esta transición afecta ciertos complementos, los cuales deben adaptarse al nuevo modelo o no trabajarán de forma adecuada, y serán marcados como incompatibles. Estamos notificando a los desarrolladores de complementos de distintas formas, esto con el fin de que puedan verificar cuáles de sus complementos serán afectados, para que puedan actualizar sus complementos y hacerlos compatibles.

Ahora hay una manera en la que tú puedes ayudar a ampliar nuestros esfuerzos, y es de la siguiente manera: reportando complementos incompatibles.

El Add-on Compatibility Reporter (ACR) te permite comunicarnos si un complemento trabaja en una versión de Firefox en particular. Estos reportes han sido una herramienta muy útil para nosotros al momento de rastrear complementos incompatibles y ayudar a los desarrolladores a solucionar esto. Los desarrolladores son capaces de ver los reportes que tú envíes para sus complementos. Si quieres probarlo te recomendamos que lo hagas en una versión preliminar de Firefox: Beta, Developer Edition o Nightly. Estas versiones cuentan con el multiproceso habilitado para todos los complementos de forma predeterminada.

Las últimas versiones de ACR incluyen soporte para multiproceso en Firefox. Una vez instalado el complemento, verás cuáles de tus complementos cuentan ya con compatibilidad para multiproceso. Verás de igual manera si tu versión de Firefox cuenta con multiproceso habilitado. Y los íconos te permitirán reportar si un complemento trabaja de forma adecuada o no.

Popup de ACRTambién podrás realizar todo esto desde el administrador de complementos, si tú lo deseas.

Administrador de complementosPara determinar si un complemento es compatible con el multiproceso, ACR busca un indicador dentro del manifiesto de ese complemento establecido por el desarrollador. Así que, por ejemplo, Password Exporter aparece como no compatible aunque trabaje de forma correcta con el multiproceso habilitado. Yo mantengo Password Exporter y no he actualizado aún el manifiesto de mi complemento para que refleje esto (¡lo haré pronto!) y es por esta razón que aparece como no compatible.

Saber cuáles complementos trabajan bien con el multiproceso en Firefox es crítico para una transición exitosa, así que esperamos que puedas ayudarnos instalando el Add-on Compatibility Reporter y dejándonos saber cuáles complementos no están trabajando bien para ti.

Visto en Mozilla México

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s